Oc-windows.ru

IT Новости из мира ПК
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Сумма четных и нечетных чисел в Excel

Сумма четных и нечетных чисел в Excel

Высчитать сумму четных либо нечетных чисел в Excel можно несколькими способами:

Стандартные функции

Первый способ возможен при использовании стандартных функций приложения. Для этого необходимо создать два дополнительных столбца с формулами:

  • Четные числа – вставляем формулу «= ЕСЛИ ( ОСТАТ(число;2) =0;число;0)», которая вернет число, в случае если оно делится на 2 без остатка.
  • Нечетные числа – вставляем формулу «= ЕСЛИ ( ОСТАТ(число;2) =1;число;0)», которая вернет число, в случае если оно не делится на 2 без остатка.

Затем необходимо определит сумму по двум столбцам с помощью функции «=СУММ()».

Плюсы данного способа в том, что он будет понятен даже тем пользователям, которые профессионально не владею приложением.

Минусы способа – приходится добавлять лишние столбцы, что не всегда удобно.

Пользовательская функция

Второй способ, является более удобным, чем первый, т.к. в нем применяется пользовательская функция, написанная на VBA – sum_num(). Функция возвращает сумму чисел в виде целого числа. Суммируются либо четные числа, либо нечетные, в зависимости от значения ее второго аргумента.

Синтаксис функции: sum_num(rng;odd):

  1. Аргумент rng – принимает диапазон ячеек, по которым необходимо произвести суммирование.
  2. Аргумент odd – принимает логическое значение ИСТИНА для четных чисел или ЛОЖЬ для нечетных.

Важно: Четными и нечетными числа могут являться только целые числа, поэтому числа, которые не соответствуют определению целого числа, игнорируются. Также, если значением ячейки является срока, то данная строка не участвует в расчете.

Плюсы: нет нужны добавлять новые столбцы; лучший контроль над данными.

Минусы заключаются в необходимости перевода файла в формат .xlsm для версий Excel, начиная с версии 2007. Также функция будет работать только в той книге, в которой она присутствует.

Использование массива

Последний способ является самым удобным, т.к. не требует создания дополнительных столбцов и программирования.

Его решение схоже с первым вариантом — они используют одни и те же формулы, но данный способ, благодаря использованию массивов, производит подсчет в одной ячейке:

  • Для четных чисел — вставляем формулу «=СУММ( ЕСЛИ ( ОСТАТ(диапазон_ячеек;2) =0;диапазон_ячеек;0))». После ввода данных в строку формул нажимаем одновременно клавиши Ctrl + Shift + Enter, чем сообщаем приложению, что данные необходимо обрабатывать как массив, и оно заключит их в фигурные скобки;
  • Для нечетных чисел — повторяем действия, но изменяем формулу «=СУММ(ЕСЛИ( ОСТАТ(диапазон_ячеек;2) =1;диапазон_ячеек;0))».

Плюсом способа является то, что все рассчитывается в одной ячейке, без дополнительных столбцов и формул.

Минусом является лишь то, что неопытные пользователи могут не понять Ваших записей.

На рисунке видно,что все способы возвращают один и тот же результат, какой лучше, необходимо выбирать под конкретную задачу.

Читать еще:  Что делать, если не работает поиск Google на планшете

Как посчитать сумму квадратов в Excel

Логотип Microsoft Excel на сером фоне

Нахождение суммы квадратов в Microsoft Excel может быть повторяющейся задачей. Наиболее очевидная формула требует ввода большого количества данных, хотя есть менее известный вариант, который приведет вас в то же место.

Нахождение суммы квадратов для нескольких ячеек

Начните новый столбец в любом месте электронной таблицы Excel и пометьте его. Здесь мы выведем решение наших квадратов. Квадраты не обязательно должны быть рядом друг с другом, как и секция вывода; это может быть где угодно на странице.

добавить новый столбец

Введите следующую формулу в первую ячейку нового столбца:

формула суммирования excel

Отсюда вы можете вручную добавить буквенно-цифровую комбинацию столбца и строки или просто щелкнуть мышью. Мы будем использовать мышь, которая автоматически заполняет этот раздел формулы ячейкой A2.

добавить ячейку a2

Добавьте запятую, а затем мы добавим следующий номер, на этот раз из B2. Просто введите B2 в формулу или щелкните соответствующую ячейку, чтобы заполнить ее автоматически.

добавить ячейку b2

Закройте скобки и нажмите «Enter» на клавиатуре, чтобы отобразить сумму обоих квадратов. В качестве альтернативы, если вы можете продолжить здесь, добавьте дополнительные ячейки, разделив каждую запятую в формуле.

закрывающая скобка

Чтобы применить формулу к дополнительным ячейкам, найдите маленький залитый квадрат в ячейке, содержащей решение нашей первой проблемы. В этом примере это C2.

найти коробку

Щелкните квадрат и перетащите его до последней строки пар чисел, чтобы автоматически сложить сумму остальных квадратов.

перетащить вниз

Нахождение суммы квадратов всего для нескольких ячеек

В нашем столбце «Сумма квадратов», который мы создали в предыдущем примере, в данном случае C2, начните вводить следующую формулу:

простая формула для суммы квадратов

В качестве альтернативы мы можем просто добавить числа вместо ячеек в формулу, так как в любом случае мы попадем в одно и то же место. Эта формула выглядит так:

простая формула для суммы квадратов

Вы можете изменять эти формулы по мере необходимости, изменяя ячейки, добавляя дополнительные числа или находя сумму квадратов, которых даже нет в вашей книге. И хотя легче следовать приведенному выше руководству, используя формулу SUMSQ, чтобы найти решение для нескольких квадратов, часто проще просто ввести быструю формулу, подобную этой, если вы не будете повторять ее на протяжении всей книги.

Как настроить в экселе сумму столбца

Как посчитать сумму в столбце Excel

Многие пользователи знают о табличном процессоре Excel. Кто-то устанавливал его просто для открытия таблиц, а кто-то — для их составления. Часто во время внесения в таблицу данных может понадобиться калькулятор, чтобы посчитать немаленькие числа. Так что для экономии нашего времени функция суммирования (вычитания, умножения и вычитания) была встроена в Эксель. Однако не все знают, как применять её. Именно об этом и будет идти речь в статье.

Читать еще:  Как включить Дзен в Яндекс Браузере

Как посчитать сумму в столбце

На самом деле, способов для суммирования чисел в столбце несколько, и все мы подробно рассмотрим. Но для начала возьмём любую таблицу для примера.

Таблица для примера

Способ 1: Ввод ячеек

  1. Итак, в конце необходимого столбца выделяем ячейку, где нужно вывести сумму чисел. В ней вводим символ «=» («Равно», без кавычек). После него пишем любую ячейку данного столбца, значок «+», ячейку, «+», ячейку и так далее. Сначала пишется заглавная буква ячейки, а потом цифра. Если всё правильно, то цвет надписей будет меняться, а ячейки — выделяться.

Ввод ячеек

Результат ввода ячеек

Способ 2: Выделение столбца

Этот способ напоминает предыдущий. Но этот будет намного проще, так как вводиться формула будет сама.

    Точно также мы выделяем ячейку под столбцом и пишем знак «=». Теперь нажимаем на верхнюю ячейку и зажимаем левую кнопку мыши. После этого растягиваем появившуюся рамочку до конца столбца.

Выделяем столбец

Приписываем Сумм и находим сумму

Способ 3: Отдел «Автосумма»

Этот способ отличается от всех остальных, так как здесь нужно будет обращаться к панели быстрого доступа.

    На панели инструментов находим отдел «Формулы» и переключаемся на него. Там заходим в меню «Автосумма». В нём кликаем по кнопке «Сумма».

Отдел Автосумма

Результат использования отдела -Автосумма

Способ 4: Функция «СУММЕСЛИ»

Ещё одна вспомогательная функция, с помощью которой можно задать условия суммирования.

    Заходим в отдел «Формулы» и нажимаем на «Автосумма». Теперь мы выбираем кнопку «Другие функции…».

Находим СУММЕСЛИ

Выбор СУММЕСЛИ

Вводим условия СУММЕСЛИ

Теперь Вы узнали о таких возможностях табличного процессора Excel, как суммирование чисел в столбце. Эти знания можно будет применять во время составления протоколов и отчётов, и при вводе обычных данных.

Сложение в Excel

Как в Экселе посчитать сумму

Excel – очень крутая штука, если понимать, как работать с этой программой. В приложении столько функций, что голова идет кругом, а среднестатистический пользователь не применяет на практике практически ничего. Возьмем хотя бы вопрос, как в Экселе посчитать сумму. Многие этого не знают и продолжают считать на калькуляторе, а потом вбивают в таблицу уже готовые значения.

Такой способ имеет право на жизнь, но зачем подвергать себя опасности ошибиться, когда можно автоматизировать процесс подсчета, заставив машину складывать, отнимать, делить, умножать, считать проценты и выполнять другие операции? В таком случае результат не придется перепроверять – у компьютера нет шансов ошибиться, когда речь идет о простой математике.

Простое сложение

Если все цифры расположены в один столбец, то для получения их суммы можно воспользоваться самым простым способом, который не требует применения формул.

Сумма

  1. Выделите все показатели, которые нужно сложить.
  2. Посмотрите на нижнюю строку: вы увидите среднее значение, количество переменных и сумму.

Выделять ячейки можно разными способами. Если они находятся рядом, то достаточно зажать левую кнопку мыши возле первого значения и протянуть выделение до последней переменной. Еще можно зажать клавишу Shift и нажимать на стрелку вниз на клавиатуре, выделяя последовательно ячейки, которые находятся ниже.

Если переменные разбросаны по листу, то зажмите клавишу Ctrl и щелкайте левой кнопкой по значениям, которые необходимо сложить. Сумма будет меняться с каждым щелчком, прибавляя то число, которое было только что выделено.

Формула

Excel можно использовать и в качестве калькулятора. Например, если вам нужно сложить несколько чисел, задайте в любой ячейке такую формулу:

Читать еще:  Скачать Easy Image Modifier бесплатно на компьютер

Обязательно поставьте в начале знак «=», иначе программа не поймет, что нужно не просто сложить числа, а еще и вывести значение на экран. Пробелы ставить не нужно: все знаки пишутся слитно.

Функция «Автосумма»

Автосумма

Если результат сложения нужно отразить на этом же листе, воспользуйтесь специальной кнопкой на верхней панели. По умолчанию ей задана функция «Сумма», но можно использовать её и для выполнения других расчетов. Если выделить данные, которые записаны в один столбец, а затем щелкнуть по этой кнопочке, то под столбиком появится искомая сумма.

Если цифры забиты по разным сторонам листа, а вам нужно собрать их суммировать и показать итог в определенном месте, то используйте такой алгоритм действий:

Сложение

  1. Поставьте в ячейке, где должна быть сумма, знак «=».
  2. Кликните по первой переменной, которую нужно использовать при сложении. Её адрес появится после знака «=».

Дальше вы можете использовать два метода: зажать клавишу Ctrl и левой кнопкой последовательно выделить все переменные или просто вписать адреса ячеек в формулу через знак «+». Выбор способа зависит от того, сколько чисел необходимо сложить. Когда все адреса ячеек будут вбиты в формулу, нажмите Enter. Вместо большого количества знаков отобразится сумма переменных, добавленных в формулу.

Использование формулы

Если подразумевается, что на листе есть специальная ячейка для суммы числе, то вывести в неё результат можно с помощью несложной формулы, которую осваивают школьники на уроках информатики.

  1. Поставьте курсор на ту ячейку, в которой должен отображаться результат выполнения арифметических действий.
  2. Нажмите на «fx», чтобы открыть список функций. Выберите «СУММ» и нажмите «ОК».Функции
  3. Укажите диапазон ячеек, содержимое которых следует суммировать.Диапазон

Выбирая числа, вы можете использовать два типа подстановок:

  • =СУММ(B1:B10) – сложение всех значений, которые закреплены в диапазоне B1-B10.
  • =СУММ(B1;B10) – сложение значений в ячейках B1 и B10.

Чтобы не перепутать разделительные знаки, сворачивайте окошко и выбирайте ячейки вручную. Заполните первое число, второе и так далее, а затем нажмите «ОК». В результате проведения операция в выделенной ячейке отобразится результат сложения.

Ссылка на основную публикацию
Adblock
detector
×
×