Особенности и преимущества новых коммутаторов Huawei серии S5300 - IT Новости из мира ПК
Oc-windows.ru

IT Новости из мира ПК
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Работа с коммутаторами Quidway S2326TP-EI

Работа с коммутаторами Quidway S2326TP-EI

Коммутаторы серии Quidway являются функциональным решением для операторов связи любого уровня. 24 медных порта используются для подключения конечных пользователей, 2 uplink порта дают возможность подключения устройства к вышестоящим коммутаторам “уровня агрегации”. В случае большой нагрузки позволяют организовать единый канал.
Суммарная скорость всех портов коммутатора составляет около 8,8 Гб/c.
Размер таблицы мак-адресов — 8000. Этого значения хватает для решения любых сетевых задач. Количество поддерживаемых VLAN составляет 4096.
Коммутаторы данной серии обладают возможностью управления по протоколу SNMPv1/v2c/v3, SSHv2. Поддерживают IPV6, IGMPv1/v2c/v3 и авторизацию по протоколу EEE 802.1x.

Распространенные команды, используемые при работе с коммутатором

Оборудование Huawei построено на базе операционной системы VRP и имеет большое сходство с интерфейсом CLI Cisco IOS. В оборудовании существует 2 режима командного интерфейса:
user-view — непривилегированного режим
system-view – привилегированный режим

Команды для просмотра информации

display current-configuration — просмотр конфигурации коммутатора. Вывод команды может занимать много строк.

display current-configuration interface ethernet0/0/8 позволяет отобразить текущую конфигурацию для определенного интерфейса, например

display interface — просмотр состояния порта

Если в команде не был указан конкретный интерфейс, то команда отобразит информацию обо всех интерфейсах на коммутаторе.

Просмотр информации абонентского интерфейса

В домовых сетях для связи между коммутаторами используются гигабитные порты. Просмотр информации UPLINK интерфейса.

display mac-address — просмотр мак-адреса

При указании номера интерфейса команда покажет информацию о мак-адресах на конкретно заданном интерфейсе, например:

Отбор данных по заданному признаку осуществляется с помощью include. Например, нам необходимо найти порт на коммутаторе, зная только мак-адрес оборудования. В этом случае нам поможет следующая команда:

Результат отработки команды показывает, что нужный нам мак-адрес 1caf-f762-b607 находится на 2 порту коммутатора.

display interface description — просмотр описания портов коммутатора.

Описание (description) можно изменить на свое. Это очень важно и позволяет прописать необходимую служебную информацию, например

display interface brief — просмотр информации о интерфейсах в виде сводной таблицы

display ip interface brief — просмотр информации o назначенных IP-адресах на интерфейсах в виде сводной таблицы.

display arp dynamic — просмотр ARP таблицы. ARP таблица показывает соответствие мак-адреса с IP-адресом.

Если необходимо найти ARP запись, зная мак-адрес устройства, то можно использовать фильтр как показано ниже:

display vlan — просмотр информации о созданных виртуальных каналах VLAN

display interface-statictics — просмотр статистики интерфейса.

Позволяет проверить загрузку канала и выявить рост ошибок

Команды для управления интерфейсами

shutdown и undo shutdown — включение/отключение административной блокировки интерфейса.

Команды работают в режиме system

Включение административной блокировки

После данной команды информация о состоянии интерфейса будет выглядеть следующим образом

undo shutdown — снятие административной блокировки порта.

virtual-cable-test — проверка длины кабеля от порта коммутатора до абонентского устройства.

reset counters Ethernet0/0/3 — позволяет сбросить счетчики статистики на выбранном интерфейсе, например

display log — выводит лог работы порта. Данная информация позволит собрать статистику работы порта и определить источник проблемы.

Для просмотра логов конкретного порта необходимо набрать следующую команду:

display patch-information — выводит информацию о установленных патчах

display current-configuration — просмотр конфигурации порта

Команды для настройки VLAN

Для создания VLAN используется команда vlan
Например:

Для удаления VLAN — undo vlan

Настройка VLAN для access порта

В режиме конфигурирования интерфейса задаем режим работы порта — access.

[huawei-GigabitEthernet0/0/1] port link-type access

После указываем номер VLAN (по умолчанию на порту используется VLAN-ID 1)

[huawei-GigabitEthernet0/0/1] port default vlan

Настройка VLAN для trunk порта

В режиме конфигурирования интерфейса задем тип — trunk.

[huawei-GigabitEthernet0/0/1] port link-type trunk

Добавляем номера VLAN в trunk через пробел или диапазон.

[huawei-GigabitEthernet0/0/1] port trunk allow-pass vlan

Настройка VLAN для hybrid порта

В режиме конфигурирования интерфейса задем тип — hybrid.

[huawei-GigabitEthernet0/0/1] port link-type hybrid

Добавляем номера тегированных VLAN.

[huawei-GigabitEthernet0/0/1] port hybrid tagged vlan

Добавляем номера нетегированных VLAN.

[huawei-GigabitEthernet0/0/1] port hybrid untagged vlan

Добавляем PVID для нетегированной VLAN, по умолчанию используется PVID = 1

Читать еще:  Как открыть файл формата PPTX: 6 вариантов

[huawei-GigabitEthernet0/0/1] port hybrid pvid vlan

it_donnet

Блог о сетевых устройствах, тестировании различных устройств. На сайте вы найдете инструкции для настройки различных устройств. А раздел «Путешествие» поможет познакомиться с интересными местами.

Первичная настройка коммутатора Huawei

Одной из крупнейших китайских компаний, которая присутствует на Российском рынке телекоммуникаций, является компания Huawei. Этот мировой гигант выпускает великое множество разнообразных моделей коммутаторов и маршрутизаторов. В данной статье мы рассмотрим первичную настройку коммутатора, а также, как к нему подключиться и какое использовать программное обеспечение для настройки.

Необходимое оборудование и программное обеспечение

Для выполнения первичной настройки сетевого активного оборудования необходимо иметь в наличии следующее оборудование и программного обеспечение:

1) ноутбук c «COM- портом» для подключения к оборудованию СПД;

Примечание: на современных персональных компьютерах и ноутбуках «COM- порт» часто отсутствует. В этом случае потребуется переходник «USB – COM (RS 232)».

2) консольные интерфейсные кабели, в зависимости от типа настраиваемого оборудования

Установка консольного соединения c оборудованием

Подключение ноутбука к оборудованию

Подключить рабочий ноутбук с помощью консольного интерфейсного кабеля к разъему «console» оборудования На разных типах оборудования интерфейс для подключения консольного кабеля может называться по-разному, возможные варианты – «console», «con», «monitor» и т.п.

Установка соединения с использованием ПО «HyperTerminal»

1) Скачать программу « HyperTerminal » из любого сайта и скопировать на локальный жесткий диск.

2) Запустить программу «HyperTerminal». В появившемся окне в поле «Название» ввести произвольное название сеанса подключения

3) В следующем окне выбрать последовательный порт ПК, к которому подключен интерфейсный кабель и нажать кнопку «ОК»

Важно! Если используется переходник «USB-COM», то номер порта может отличаться от «COM1». Проверить это можно в «Диспетчере устройств» Windows в разделе «Порты (COM и LPT)»

Если номер порта будет отличаться (например, «COM6»), то поменять значение в поле «Подключаться через» с «COM1» на «COM6».

Установить параметры порта в ПО «HyperTerminal» с настройками в соответствии с рисунком ниже и нажать кнопку «ОК».

Общая начальная настройка коммутатора

1) После включения питания коммутатора система предложит ввести имя пользователя и пароль. По умолчанию имя пользователя для первого входа — admin, пароль — admin@huawei.com.

2) Необходимо изменить пароль во время первого входа

3) После изменения настройки пароля система выдаст приглашение к началу конфигурирования:

4) Войти в привилегированный режим

<Huawei> system-view

После входа в конфигурационный режим вид строки приглашения изменится на:

5) Необходимо изменить имя коммутатора:

[Huawei] sysname SW1

В данном примере –имя коммутатора будет «SW1», вид строки приглашения изменится на:

6) Войти в режим конфигурирования доступа по консоли:

[SW1] user-interface console 0

7) Задать пароль:

[SW1-ui-console0] set authentication password cipher Huawei

В данном примере- пароль будет «Huawei».

8) Выйти из режима конфигурирования доступа по консоли:

[SW1-ui-console0] quit

9) Войти в режим конфигурирования доступа по протоколу telnet:

[SW1] user-interface vty 0 4

10) Задать пароль:

[SW1-ui-vty0-4] set authentication password simple Huawei

В данном примере- пароль будет «Huawei».

11) Установить режим проверки подлинности пользователей по паролю:

[SW1 -ui-vty0-4] authentication-mode password

12) Выйти из режима конфигурирования доступа по протоколу telnet:

[SW1 -ui-vty0-4] quit

Настройка интерфейсов коммутатора

1) Войти в режим конфигурирования интерфейса:

[R1] interface Vlanif 1

2) Назначить IP-адрес хxх.хxх.хxх.хxх интерфейсу:

[R1-Vlanif1] ip address xxx.xxx.xxx.xxx yy

где хxх.хxх.хxх.хxх – ip адрес, yy – префикс маски подсети.

3) Выйти из режима конфигурирования интерфейса:

[SW1-Vlanif1] quit

4) Назначить шлюз по умолчанию:

[Huawei] ip route-static zzz.zzz.zzz.zzz

где zzz.zzz.zzz.zzz – ip адрес шлюза

5) Выйти из конфигурационного режима:

[SW1] quit

6) Сохранить текущую конфигурацию:

[SW1] save

Настройка транкового порта (Trunk port) коммутатора

«Trunk port» или «Магистральный порт» — это канал типа «точка-точка» между коммутатором и другим сетевым устройством. Магистральные подключения служат для передачи трафика нескольких VLAN через один канал и обеспечивают им доступ ко всей сети. Магистральные порты необходимы для передачи трафика нескольких VLAN между устройствами при соединении двух коммутаторов, коммутатора и маршрутизатора.

Читать еще:  Как найти магазин на AliExpress

Войти в режим конфигурирования интерфейса:

[SW1] interface Ethernet0/0/0

1) Перевести порт в состояние trunk:

[SW1-Ethernet0/0/0] port link-type trunk

2) Выйти из режима конфигурирования интерфейса:

[SW1- Ethernet0/0/0] quit

3) Сохранить текущую конфигурацию:

[SW1] save

Сброс настроек коммутатора Huawei в заводские без доступа к системе

1) Подключить рабочий ноутбук к коммутатору и запустить телекоммуникационное программное обеспечение согласно.

2) Подать питание на коммутатор. Дождавшись строки «Press Ctrl+B to break auto startup» при загрузке коммутатора, нажать на клавиатуре сочетание клавиш «Ctrl+B» (дается на это не более 3 секунд, после чего продолжается загрузка устройства).

3) На запрос пароля ввести «Admin@huawei.com» (в некоторых версиях возможен вариант пароля «huawei»). В появившемся после успешного ввода пароля «BOOTROM Menu» на клавиатуре нажать кнопку «5» («Enter filesystem submenu») и после этого клавишу «Enter».

4) В открывшемся подменю «FILESYSTEM SUBMENU» на клавиатуре нажать кнопку «3» («Delete file from Flash»), после этого клавишу «Enter», выводится список файлов, которые есть в файловой системе.

5) В списке найти cfg-файл

и ввести его имя в строку приглашения «Please choose the file you want to delete:». В данном примере это «test-sw.cfg». Подтвердить удаление файла, нажав на клавиатуре кнопку «y».

6) После удаления файла конфигурации в «FILESYSTEM SUBMENU» для возврата в «BOOTROM MENU» нажать кнопку «6» и после этого клавишу «Enter».
7) Нажать на клавиатуре кнопку «7» («Reboot») и после этого клавишу «Enter».
8) После перезагрузки выполнение первичной настройки осуществляется с п. 3 настоящей инструкции.

Коммутаторы Huawei S3700 для крупных и сложных сетевых инфраструктур

Корпоративные коммутаторы Huawei S3700 представляют собой современные коммутаторы 3 уровня, характеризующиеся отличной энергоэффективностью. Они обеспечивают доступ с отличной скоростью маршрутизации и позволяют агрегировать корпоративные сети кампусного типа.

Коммутаторы Huawei S3700

Коммутаторы Huawei S3700 третьего уровня ориентированы на корпоративный сектор и обеспечивают высокоэффективный доступ и агрегацию траффика в сетях предприятий. Устройство выполнено в корпусе 1U, компанией предусмотрено три варианта поставки устройства: стандартная версия (SI), улучшенная версия (EI) и расширенная версия (HI). Отличие конфигураций заключается в реализации сложных протоколов маршрутизации, большего набора функций и поддержке большего количества спецификаций MAC-адресов, маршрутов и элементов многоадресной передачи в версиях EI и HI. Базовая версия SI полностью реализует функции второго уровня и базовые функции третьего уровня. Во всех версиях коммутаторов Quidway S3700 установлено аппаратное и программное обеспечение Универсальной Платформы Маршрутизации VRP, позволяющее использовать возможности устройства на сто процентов. К основным функциям маршрутизаторов относятся Multi-VPN-Instance CE (MCE), а также функционал для многоадресной передачи данных, то есть IGMP-отслеживание, IGMP-фильтрация, быстрое отключение (fast leave) и IGMP-прокси. Multi-VPN-Instance служит для того, чтобы изолировать разные VLAN на одной машине, что дает большую защиту информации. К стандартному функционалу маршрутизаторов также относится репликация многоадресных пакетов между сетями VLAN, а также равное распределение нагрузки при многоадресной рассылке между интерфейсами на транке.

Безопасность данных и всеобъемлющие политики QoS

Инженеры Huawei серьезно подходят к вопросу безопасности корпоративных данных, а потому во всех маршрутизаторах Quidway реализованы механизмы, обеспечивающие защиту передаваемой информации:

  • Сложная классификация передаваемого траффика, основанная на информации IP-пакета. Есть возможность ограничения траффика на основе маркировки потоков;
  • Реализованы функции защиты от атак DoS;
  • Реализована функция DHCP-слежения. С помощью DCHP-слежения можно фильтровать нелегальные пакеты, такие как, пакеты имитации ARP-запросов и пакеты с поддельными IP-адресами. Благодаря этой функции корпоративная сеть будет защищена от перехвата с участием человека;
  • Запоминание ARP-адресов, благодаря чему предотвращаются атаки имитации ARP-запросов. Кроме этого, в коммутаторах реализована функция проверки IP-адреса источника, что обеспечивает защиту от атак отказа в обслуживании, используя поддельные MAC-адреса, либо IP-адреса.
  • Возможность ограничения количества MAC-адресов, заученных на интерфейсе. Эта функция предотвращает атаки с использованием поддельных MAC-адресов источников.

Маршрутизация IPv4 и IPv6

В маршрутизаторах Huawei S3700 реализованы такие протоколы маршрутизации, как RIPv1, RIPv2, OSPF, IS-IS и BGP. Имеется поддержка двойного стека IPv4/IPv6, туннелей IPv6 над туннелями IPv4 и коммутацию третьего уровня. Благодаря такому функционалу маршрутизаторы оптимально для миграции сети от IPv4 к IPv6.

Читать еще:  Почему гаснет монитор во время работы компьютера

Надежность и масштабируемость

Помимо высоких характеристик производительности и защищенности данных маршрутизаторы Huawei S3700 отлично масштабируются благодаря функции интеллектуального стека (iStack). С помощью этой функции несколько устройств можно объединить и они будут работать как один виртуальный коммутатор. Надежность работы сети гарантируется расширенной технологией Smart Link и RRPP, реализующей защитное переключение канал практически мгновенно. Технология BFD автоматически распознает неисправности для протоколов OSPF, IS-IS, VRRP и PIM.

Конструкция и энергопотребление

Quidway S3700 не требуют постоянного управления и поддерживают удаленное обновление ПО. С помощью протокола GARP VLAN Registration Protocol происходит динамическое назначение, регистрация и объявление атрибутов виртуальных сетей VLAN, что сокращает работу системных администраторов. Принципиальной особенностью коммутаторов с 24-мя электрическими портами является конструкция без использования вентиляторов, что существенно снижает затраты на эксплуатацию и уровень шума. Кроме этого, в S3700 используются энергосберегающие интегральные схемы, а неиспользуемые порты функционируют в спящем режиме, сокращая энергопотребление.

Утилизация аппаратных ресурсов на коммутаторах Huawei S-серии

У коммутаторов Huawei S-серии имеется возможность просмотра используемых аппаратных ресурсов (в частности, утилизации tcam) и перераспределения (для некоторых конфигураций модульных коммутаторов).

Ресурс ACL это в самом деле ресурс, используемый для traffic-policy (и прочих вариаций traffic-*) и, в некоторых случая, Selective QinQ (когда является особым traffic-policy). Имеется три типа ресурсов ACL – rule(классикация трафика), counter(подсчёт трафика), meter(ограничение скорости)
В случае с S9300 это выглядит следующим образом:

Как видно из этой таблицы, ресурсы раздельны для traffic-policy по отношению к vlan, ingress ACL и egress ACL.

Применим следующую политику:

И смотрим на изменившиеся значения ресурсов ACL:

Как видно, использовано 2 единицы ресурса rule и 2 единицы counter (потому что 2 правила и по каждому нужно считать трафик(statistics enable в behavior)), meter не используется, т.к. скоростные политики не задействованы в этом traffic-policy.

Используя большие ACL или какой-либо функционал, генерирующий их динамически, нужно следить за исчерпанием этих ресурсов.

Selective QinQ

В зависимости от конкретной модели, selective QinQ может быть реализован по-разному (с точки зрения потреблени hw ресурсов). Раньше это вообще не выделялось в отдельную фичу и явным образом реализовывалось с помощью traffic-policy, суть которого “match c-vlan -> add s-vlan”(пример, архив)

В современном варианте, selective QinQ настраивается следующим образом (на S9300):

И занимает это 2 единицы аппаратного ресурса vlan_xlate:

Чтобы просмотривать эти и другие записи, нужно воспользоваться командой “display bcmfpi table …”

Просматривать ресурсы acl тоже можно через display bcmfpi resource, но это менее удобно, чем через “display acl resource” и кроме того, команда “display bcmfpi” есть далеко не на всех свитчах.

Ресурсы l2, l3, mpls

По аналогии с vlan_xlate, ресурсы мак-таблицы, arp-таблицы, mpls-меток и т.д. можно смотреть с помощью “display bcmfpi resource”. Довольно быстро можно исчерпать ресурс mpls-меток, типичное максимальное значение которого – 8K. Проверить ресурс меток можно командой “display bcmfpi resource slot X mpls vc-swap-table”. Традиционные решения для минимизации этой таблицы – использование per-vrf label allocation и выделение меток в GRT только лупбэкам (а не каждому префиксу).

Перераспределение TCAM в сторону тех или иных ресурсов, для S9300, осуществляется командой “assign resource-mode X” (если есть что перераспределять)

Буферы коммутации

В отличии от предыдущих ресурсов, которые хранят те или иные таблицы/правила передачи трафика, буферы хранят непосредственно трафик. Значимость буферов коммутации была описана ранее (Burst vs буфер коммутации).
Для свитчей S5300HI см. заметку S5300HI interface buffers. Buffering issues (архив)

Для того, чтобы понять в какой очереди происходят дропы, на S9300 “display qos queue statistics interface GigabitEthernet 6/1/1”, на S5300(EI) “display qos port statistics interface GigabitEthernet 0/0/1”, предварительно включив сбор статистики командой “qos port statistics enable interface GigabitEthernet 0/0/1” (возможно только на одном порту)

Ссылка на основную публикацию
Adblock
detector
×
×